1. Possible delay in data processing
Incident Report for Localytics
Resolved
This incident has been resolved.
Posted over 2 years ago. Aug 10, 2015 - 09:50 HST
Identified
Things are not quite what we expect, hang tight as we are looking into it.
Posted over 2 years ago. Aug 10, 2015 - 09:37 HST