AWS Issue
Incident Report for Localytics
Resolved
A large-scale AWS issue occurred during the afternoon of 2/28 from approximately 12:30 - 4:30 pm EST, which subsequently caused S3 to go down.

At this time, Localytics' services have returned to normal and no analytics data were lost due to the outage. All data collected by the Localytics SDK during that time have been processed and will appear in the dashboard as well as S3.

Push Messaging via the API for Customer ID targets was consistently operational, but Email and Audience-based Push campaigns were delayed or not sent during the outage. Push registration information was not lost, but delayed during the incident. Targeting newly registered devices with Push may not have worked.

In-app, Inbox, and Places campaigns were operating on a cached-only mode; messages were still being displayed if the target device had downloaded the creative prior to the outage, but otherwise newly created campaigns and creatives were not transmitted to devices during that time.
Posted 7 months ago. Mar 01, 2017 - 05:03 HST
Update
A large-scale AWS issue occurred this afternoon from approximately 12:30 - 4:30 pm EST, which subsequently caused S3 to go down.

Push Messaging via the API for Customer ID targets was consistently operational, but Email and Audience-based Push campaigns were affected.

In-app, Inbox, and Places were also affected as campaigns were operating on a cached-only mode; messages were still being displayed if the target device had downloaded the creative prior to the outage, but otherwise new creatives were not transmitted to devices during that time.

At this time, we expect services to return to normal by approximately 1:00 am EST.
Posted 7 months ago. Feb 28, 2017 - 18:55 HST
Update
A large-scale AWS issue occurred this afternoon from approximately 12:30 - 4:30 pm EST, which subsequently caused S3 to go down.

Push Messaging is still operational via the API for Customer ID targets, but Email and Audience-based Push campaigns are affected.

We expect that Push and Email campaigns with start times after 4:30 pm will not be majorly impacted if the incident is resolved soon, and we are closely monitoring the situation in order to provide the most accurate timeline possible.

In-app, Inbox, and Places campaigns were operating on a cached-only mode; messages were still being displayed if the target device had downloaded the creative prior to 12:30 pm, but otherwise new creatives were not transmitted to devices.

At this time, we expect to have a full assessment of the impact later this evening.
Posted 7 months ago. Feb 28, 2017 - 12:42 HST
Investigating
A large-scale AWS issue is occurring right now, resulting in S3 being down which is impacting multiple systems:

* Data processing is delayed.
* Push Messaging is still operational via the API for Customer ID targets, but audience-based campaigns are delayed.
* S3 Log exports are currently unavailable.
* Push device registration is delayed.

We are investigating the issue and will update shortly.
Posted 7 months ago. Feb 28, 2017 - 08:22 HST