Degraded Dashboard Performance
Incident Report for Localytics
Resolved
Dashboard continues to run smoothly and we are marking this issue as resolved. The root cause was a large number of queries hitting custom reports. Normally, this type of situation should not have any impact on the overall performance of the Dashboard, but a hidden setting on one of our systems caused all queries for the Dashboard to get stacked up behind these custom report queries, which caused the slowdown. We have changed this setting and will be implementing additional safeguards to prevent this situation from happening again. If you are still experiencing issues with Dashboard, please contact Support.
Posted 4 months ago. Apr 11, 2019 - 12:44 EDT
Monitoring
We have been fully switched over to our backup systems for about a half hour and Dashboard appears to be stable once again. We continue to closely monitor the situation.
Posted 4 months ago. Apr 11, 2019 - 11:57 EDT
Update
We are working on switching over to our backup systems, but the process is taking longer than usual.
Posted 4 months ago. Apr 11, 2019 - 11:27 EDT
Identified
We've traced the root cause of this issue to our data warehouse and we are currently working on a solution.
Posted 4 months ago. Apr 11, 2019 - 11:14 EDT
Investigating
We have noticed sporadic instances of the Dashboard running slow or even failing to load. The team is currently investigating the root cause of this.
Posted 4 months ago. Apr 11, 2019 - 10:47 EDT
This incident affected: Dashboard.